0
Corrigé

Problem with Debug - downloading file instead of showing in browser

Anonyme il y a 3 ans dans Studio / Output mis à jour par Gandalf il y a 3 ans 3

Hi team

The latest release (1.1.0.55) has a bug when running a micro service, instead of showing up in the browser it downloads a xml or json file, it was working fine on the previous version. I did some debugging, it happens only when a recordset containing data from a store procedure is configured as output (see the attached image). if I click Debug, and then select "View in Browser(F7)", instead of showing it, a xml file is downloaded (see link)
Regards,
Robin Perdomo

debug

Solution

+1
Solution
Pas un bug

Hi Robin


Thanks for coming through to the community. The part of the process you are talking about is handled by your browser. Please check your browser settings:


# If you return a small result set (a few lines of xml) does it still do this?

# If you use a different browser as default does it still do this?


Some browsers (like IE) will not show JSON results as text and will force a save. Others (like Chrome) will only accept a small amount of response data without forcing you to save it.



+1
Solution
Pas un bug

Hi Robin


Thanks for coming through to the community. The part of the process you are talking about is handled by your browser. Please check your browser settings:


# If you return a small result set (a few lines of xml) does it still do this?

# If you use a different browser as default does it still do this?


Some browsers (like IE) will not show JSON results as text and will force a save. Others (like Chrome) will only accept a small amount of response data without forcing you to save it.



+2

Yo are right, after reducing the recordset and removing unnecessary fields it loads just fine. Thank you so much