Post Tool - Various issues

Wynand Vermaak 1 year ago in Studio / Toolbox updated 7 months ago 1


I recently started working on a certain part of the Price Increase Journey that worked last year. What has changed since then? Only the Warewolf version. The workflow in question is the GetPdfLinkDetails which contains an API Post to a 3rd party provider - InsideData. Please note that this API response is an escaped json format. For the sake of completeness, I'm using Warewolf

In the latest version of Warewolf, the API doesn't return a response in Warewolf. Whether the default - output to variable or output to object is selected, as per the below screenshots: 

Image 1074

Image 1075

However, we are able to get a response in Postman as per the following screenshot: 

Image 1076

I then decided to downgrade Warewolf to a version prior to Dev2's Post Tool changes. Once downgraded, upon opening the workflow, I get the following error: 

Image 1077

When I tried to delete the former Post Tool, highlighted in red, in order to drag on a new post tool, I get the following error: 

Image 1078

This concludes the issues experienced. The following is additional information to help with the troubleshooting:

1. The API in question can be called via a post request to the following URL: 

The request body is as follow (Please note - should be in Raw Text format - Not JSON:

"Campaign":"TUG - Price Increase",
"BatchName":"PostMan Test - 2022-08-01",
"DistributionTemplate": "TheUnlimitedInsurance",
"ArchiveOnly": true,
"CSVData":"TUS000721271;Journey Test;R20.0;R132.0;March 2023;Yes! You get INSTANT CASH BACK on selected groceries like bread, milk, nappies and more!",
"Name":"Journey Test",
"NumberMobile": "0726105303"
"RefDate1":"March 2023",

Lastly, the workflow in question is:


tool studio workflow explorer