+1
Answered

Connecting Studio to Server

Anonymous 3 years ago in Studio • updated by Genie 3 years ago 9
Hi,

I have downloaded the source code and currently have the server and studio running in visual studio. The problem I am having is that the studio can't find the server and throws an error. Do you have any advise to over come this issue.

Regards
Wayde

studio server
Under review
Hi Wayde

What is the error message?


Hi Wayde,

Can you please provide us with the error you are getting? Also the Studio Log (C:\Users\{UserName}\AppData\Local\Warewolf\Studio Logs) and the Server Log (C:\Program Files (x86)\Warewolf\Server\wareWolf-server.log).

Thanks
A message box appears stating: The Warewolf service isn't installed. Please re-install the Warewolf server.
@Genie, There is no server installed in the path you have specified (C:\Program Files (x86)\Warewolf\). I followed the steps outlined here "http://warewolf.io/knowledge-base/how-to-build-warewolf-from-source/".
Sorry for the inconvenience but I believe my problem is due to not having Warewolf installed on my pc, as I assumed I could run just the server with visual studio.
Hi Wayde,

You can do this, however you cannot run the Studio in Release mode with a Server running as a console. The release mode/version of the Studio expects a Server Service to be installed and running.

So easiest is to run both the Studio and Server from Visual Studio in Debug mode.

Let me know if you have any trouble on that end.
Ok thank you for all the help, I have got it running now.
Awesome! Glad to hear it. Please post any questions or comments you may have after working with Warewolf.

Thanks :)