0

AWS - My user don't apper in Security Menu and cound't add any database connector tool on flow.

Alberthan 3 months ago in Studio updated by Ashley Lewis 2 months ago 3

Hi, Im using AWS Warewolf.

1) Im the system administrator but  my user don't apper in Security Menu

2) Couldn't connect in any database, when i drag mysql tool the setting to select the source don't apper. I tried create a new db source direct but connection don't work. It's very strange because when i use it on the warewolf shared resouce the sql db connector worked.

Hi Alberthan, I am working on publishing Warewolf 2.3 for Developers as a new AMI in the Amazon Marketplace. In the meantime and because warewolf.io is down, here is a link to download 2.3 that I've just created now

https://warewolfreleases.s3-eu-west-1.amazonaws.com/Warewolf-2.3.0.1.exe

Please try with this version and ensure you are running 2.3.0.1 by executing http://localhost:3142/secure/getserverversion.json from an internet browser on the same machine that is hosting your Warewolf server or by using Warewolf Studio and right clicking on the remote server in the explorer and selecting "Server Version".

It could also help if you could provide server and studio log files located here:

"C:\ProgramData\Warewolf\Server Log\wareWolf-Server.log"

and here:

"%localappdata%\Warewolf\Studio Logs\Warewolf Studio.log"

Hi, Ashley

Now the flows was saved !

I could generate database connection, but in flow no Stored Procedures apper in Action fields. I builded 3 stored procedures in mysql database but nothing there in Mysql tool.

Sorry Alberthan,

But I'm having trouble replicating this behaviour. Just a little more information would help explain why this is happening.

  • The authentication type used in Warewolf to connect to MySQL. There are only 2 options for authentication type, "Windows" type authentication or "User" type of authentication.
  • The edition and version of the MySQL instance you were trying to connect to.
  • Any permissions on MySQL that are relevant for viewing stored procedures for the user that Warewolf is connecting as.

I believe that it's possible to configure your permissions in MySQL to allow connections to the database but not to allow viewing some or all of the stored procedures.

Thanks for being patient with me. I know that your AWS trial of Warewolf is limited in time.