0
Fixed

UAT- Facing Issue while creating unit test cases from workflow

Vijay Prajapati 8 months ago updated by Siphamandla Dube 6 months ago 5

Warewolf Version : 2.6.8 and 2.6.10

Issue Detail : When I tried to create test cases 

1) It's not display Test name in the left panel where we can see our test cases name ( it happen some time and some time it show)

2) When we see the test cases, there is Assert Mock and Assert Output Label and inside its value field not display properly It should take whole object output value.

3) When I save and run the test case if it has Post tools and mock the value. It display "The source for these tests does not exist. The window will be close when you click Ok"

Please check attached video for more detail.

Unit_TestCase_Issue.mp4

Note: I'm not able to create test case If It has dynamic data.

tool workflow

Hello Vijay,

With our investigation on this issue, we were able to find a way that can help you save time while this issue is being fixed.

Please try:

  1. Debug Workflow [F6] or [Debug] button
  2. Generate test from debug outputs button
  3. As soon as the test surface loads [F5] test run (this should also save the test)
  4. Close the test tab and reopen it (this should now show the test(s) you generated from the debug outputs following the above 1 - 3 steps)

A solution for this is underway, please take note of the changes in the status of this ticket to know when we start this work so as when it goes to the next installer.

Kind regards

Siphamandla Dube