0
Fixed

An internal error occurred while executing the service request

Retuza 1 year ago • updated by Grommit 1 year ago 5

I download warewolf and get error:

An internal error occurred while executing the service request

The workflow must have at least one service or activity connected to the Start Node.

I run in Windows 7 and 8.1 what is wrong

Under review

Hi Retuza. Thanks for coming through to the community.

We are aware of this issue and are hoping to have a release out next week with the fix.

Hi, i have the same problem (as you allready know). When i start the server through commandline as admin i get the following:

C:\Program Files (x86)\Warewolf\Server>"Warewolf Server.exe"

Loading settings provider... done.
Configure logging... done.
Loading resource catalog... done.

Web Server Started
Web server listening at http://*:3142/
Web server listening at https://*:3143/
Loading server workspace... done.
Preloading assemblies... System.IO.FileLoadException: Could not load file or assembly 'System.Windows.Interactivity, Version=4.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'System.Windows.Interactivity, Version=4.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' ---> System.IO.FileLoadException: Could not load file or assembly 'System.Windows.Interactivity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'System.Windows.Interactivity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
at System.AppDomain.Load(AssemblyName assemblyRef)
at Dev2.ServerLifecycleManager.LoadReferences(Assembly asm, HashSet`1 inspected)
at Dev2.ServerLifecycleManager.LoadReferences(Assembly asm, HashSet`1 inspected)
at Dev2.ServerLifecycleManager.LoadReferences(Assembly asm, HashSet`1 inspected)
at Dev2.ServerLifecycleManager.LoadReferences(Assembly asm, HashSet`1 inspected)
at Dev2.ServerLifecycleManager.LoadReferences(Assembly asm, HashSet`1 inspected)
at Dev2.ServerLifecycleManager.PreloadReferences()
at Dev2.ServerLifecycleManager.LoadActivityCache(ResourceCatalog catalog)
at Dev2.ServerLifecycleManager.Run(Boolean interactiveMode)


Exiting with exitcode 0

Hi Jacob. We are working on a hot fix now and should have a release up shortly. Thanks for the information.
It appears the issue is only on new installs. So a workaround for right now is:


1. Uninstall Warewolf

2. Install the previous version

3. Upgrade to the latest version.


Alternatively, we are pushing for the hot fix to be up some time Saturday 1 October..

Great thank you! previous version is working fine :)

Fixed

This has been resolved - version 1.2.1.7 is available at https://warewolf.io/release-notes.php or alternatively click the New Version button at the bottom left in the Studio.