0
Under review

HTTPS connection from localhost to a remote server

keith_k 2 years ago in Server • updated by Gandalf 2 years ago 3

How do you add an SSL certificate or what is needed to make an HTTPS connection to a web server?


When I click New Remote Server, I am able to successfully connect to my remote server with http://ipaddress:3142 as the address and Microsoft User/Password authentication. However, I receive the following error when trying to connect with https://ipaddress:3143


Connection Error : An error occurred while sending the request.


Notes:

My remote server is a VM through Microsoft Azure. The VM was created with the Warewolf ESB, so the HTTP: TCP/3142 and HTTPS: TCP/3143 inbound security rules are all in place. Also, I can successfully connect to my localhost machine from the remote server with both HTTP/HTTPS.


deploy server

Hi I'm Ashley, I do the versioning for Warewolf.


Could you do me a favour and post your server version? You should be able to get it from http://ipaddress:3142/services/GetServerVersion


Also, when did you log into the Azure VM for the first time? (Your version should be latest version as of that time)


If you could also find and post the server log file, it should be at %programfiles(x86)%\Warewolf\Server\warewolf-server.log


Thank you so much for raising this issue. And if you do get back to us thank you for doing us this huge favour.


EDIT: You might wanna send the server log file to alpha@warewolf.io instead of posting it here as it may contain sensitive information.

Hi Ashley,


Thank you for the reply and help. I will email you the server log file. I received an error when running the GetServerVersion.


I created and logged into the Azure VM for the first time about 10 days ago. I just did again now and was able to retrieve the server log. I'll email that over as well.


Thanks,

Keith

Under review

Hi Keith


Did you get this resolved? Is anything else you need a hand with on this ticket?


Regards