0
Fixed
Anonymous 10 months ago in Installer • updated by Gandalf 9 months ago 2

2016-06-29 22:55:59,218 [4] ERROR - System.Configuration.ConfigurationErrorsException: Failed to decrypt using provider 'RsaProtectedConfigurationProvider'. Error message from the provider: The RSA key container could not be opened. (C:\Program Files (x86)\Warewolf\Server\Warewolf Server.exe.secureconfig line 3) ---> System.Configuration.ConfigurationErrorsException: The RSA key container could not be opened.

at System.Configuration.RsaProtectedConfigurationProvider.ThrowBetterException(Boolean keyMustExist)
at System.Configuration.RsaProtectedConfigurationProvider.GetCryptoServiceProvider(Boolean exportable, Boolean keyMustExist)
at System.Configuration.RsaProtectedConfigurationProvider.Decrypt(XmlNode encryptedNode)
at System.Configuration.ProtectedConfigurationSection.DecryptSection(String encryptedXml, ProtectedConfigurationProvider provider)
at System.Configuration.RuntimeConfigurationRecord.CallHostDecryptSection(String encryptedXml, ProtectedConfigurationProvider protectionProvider, ProtectedConfigurationSection protectedConfig)
at System.Configuration.BaseConfigurationRecord.DecryptConfigSection(ConfigXmlReader reader, ProtectedConfigurationProvider protectionProvider)
--- End of inner exception stack trace ---
at System.Configuration.BaseConfigurationRecord.EvaluateOne(String[] keys, SectionInput input, Boolean isTrusted, FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult)
at System.Configuration.BaseConfigurationRecord.Evaluate(FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult, Boolean getLkg, Boolean getRuntimeObject, Object& result, Object& resultRuntimeObject)
at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
at Dev2.Runtime.Security.HostSecureConfig..ctor()
Answer
Gandalf 9 months ago

Hi,


Thanks for the bug report. We currently investigating the cause of this bug.

+1
Fixed
Anonymous 2 years ago in Installer • updated by Genie 2 years ago 16
Hi

Warewolf installation stuck at starting Warewolf server on Pre Install tick.with process bar 90% complete.
OS , Windows 7 32 Bit

Surya
server
0
Answered
Anonymous 3 years ago in Installer • updated by Gandalf 3 years ago 1
On installation I am getting this message failed to open firewall port 3143 and 3142, so how do I fix it?
installer
0
Answered
Anonymous 3 years ago in Installer • updated by Gandalf 3 years ago 0
Hello, I am having problem with the the installation. I get the message "Cannot Start Server Service" and the option to Try again. Is there something I can do in my computer settings to fix this?

http://tinypic.com/view.php?pic=15hd086&s=8#.UzUhbfmSzg8 
server installer
Answer
Gandalf 3 years ago
Make sure you are running the installer from the machine that Warewolf is being installed onto. Installing over the network will cause this problem.

If that is not the case, try manually starting it in Windows Task Manager > Services > Warewolf Server

Still having problems, then please log a bug and attache the following:

  • C:\Program Files (x86)\Warewolf\Server\wareWolf-Server.log
  • C:\Program Files (x86)\Warewolf\Server\Warewolf Server.InstallLog 
  • C:\%localappdata%\Warewolf\Warewolf_Install.log


0
Answered
Lion King 3 years ago in Installer • updated by Gandalf 3 years ago 1
If you get this error it means you are a non-admin user who was not prompted to enter admin credentials when running the installer.
This can happen if your User Account Control (UAC) settings are set to Never notify.


Figure 1 : UAC off in Control Panel

To change your UAC level first open your control panel from the start menu.
Then search for uac and click on Change User Account Control settings. 
You will need to be an administrator to do this.

Figure 2 : Control Panel with UAC search

Then change your UAC settings back to Default as seen below.
Click OK and close the Control Panel window.
Try installing again.

Figure 3 : Restore Default UAC
 
installer
+1
Fixed
Anonymous 4 years ago in Installer • updated by Gandalf 4 years ago 0
Running windows 7 ultimate 64bit.When trying to install i get presented with a error dialog saying normal instalation not supported.


Answer
Gandalf 4 years ago

While we investigate, could you please try right clicking on the installer and running as administrator to see if you can install?

 

0
Fixed
Anonymous 4 years ago in Installer • updated by Lion King 4 years ago 0

Cannot install --> "Running Gui.exe failed:193"

Answer
Lion King 4 years ago

The issue was related to the way we built the Installer. We have corrected this and uploaded a revised installer to http://warewolf.io/download


Please download from the link above and try installing again. 

+1
Fixed
Anonymous 4 years ago in Installer • updated by Gandalf 4 years ago 1

I installed your software in an EC2 Instance running a Win 2k8 Data Center.
The installer detected a .NET 4.5 requirement that it downloaded and installed fine. Upon reboot the Warewolf installer started up again but jumped straight to the finish screen.

I needed to reinstall to properly start the server and use the studio.

And an installer category might be a good idea for posting feedback...


installer
Answer
Gandalf 4 years ago

Fixed. Good find!